2019 Thesaurus Payroll Manager - System Requirements

 

Thesaurus Payroll Manager is compatible with the following versions of Microsoft Windows:

 

 


Please note: Windows XP and Windows Vista are no longer supported. This is due to Revenue only accepting transmissions using TLS 1.2 security, which is only supported on Windows 7 or higher. 

 

 

 

Need help? Support is available at 01 8352074 or support@thesaurus.ie.

Help2019 Thesaurus Payroll Manager - System Requirements2019 Budget - Employer SummaryPayroll CalendarPayroll DeductionsGetting startedImporting from previous yearImporting from other Payroll SoftwareMigrating to Thesaurus Payroll Manager Mid Tax-YearCompany SetupDigital CertificatesAdd/ Amend EmployeesRevenue Payroll Notifications (RPNs)Processing PayrollPayroll Submission Requests (PSRs)Distributing PayslipsPaying EmployeesCorrectionsRevenue PaymentsReportsProcessing StartersProcessing LeaversBenefit in KindIllness BenefitMaternity BenefitPaternity BenefitPensionsChanging an Employee's Pay FrequencyYear End - 2019Backup and RestoreCSOHolidaysLeave EntitlementsEmployment LawGeneralGlossary of Terms (Pre 2019)Revenue - Contact Telephone NumbersTransferring Payroll Manager from one PC to anotherThesaurus ConnectGDPREnd User Licence Agreement for Thesaurus Payroll Manager